Moovly is a browser-based platform that’s supported by the following browsers: Chrome, Firefox, Safari and Internet Explorer (running on Windows or Mac OSX). Older versions of these browsers or operating systems might not be fully supported.

The Moovly Editor is Adobe Flash based, so be sure to update your Flash version regularly. The minimum version of Adobe Flash required is 11.1. You can check if Flash is installed on your computer (and if so, which version) here.

Moovly is not yet available as an app for Android. Downloaded or published Moovly videos, however, can be viewed on any device.